All posts in “Troubleshooting”

Picture of hub 3.0 white and black

White Colour Power Light LED And Green Wifi To Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has a green wifi flashing and power is white

Troubleshoot !

My router or hub 3.0 has a green wifi light flashing and the power is white colour, what is happening?

Hub 3.0 troublesoot

Hub 3.0 with White Power led and green wifi

Remedy !

There are few things that can cause this, see below:

  • First – The hub 3.0 has done some updates in the background and now they are stuck, causing errors, try restarting it.
  • Second – The hub 3.0 is using a very congested wifi channels, you could reset it, see here.
  • Third – Do not confuze this with WPS searching as that option lasts up to 2 minutes.
  • Forth – If the reset doesn’t work the try my tutorial and optimize it manually, remember to put 2.4 Gh band to channel 11 and 5 Gh band to channel 44, see here.

If by any reason the hub 3.0 is behaving the same and you have fallowed the instructions above, then call virgin up to investigate further.

Power Flashing And Wifi Light Is Green Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has the power flashing green and the wifi light is green

Troubleshoot !

The hub 3.0 router from virgin media is showing flashing green power light and wifi is green colour. You got no connection what so ever.

Hub 3.0 troublesoot

Hub 3.0 with green power led and wifi green

Remedy !

This issue means that the cable is disconnected, very damaged or maybe cut of in the garden.

  • First – You have to check the coax cable and make sure it’s securely connected.
  • Second – You can check the virgin media website on any known outages on the network, see here.

If by any reason the hub 3.0 is behaving the same and you have fallowed the instructions above, then call virgin up to investigate further, probably an engineer is required.

Picture of hub 3.0 white and black

Red Colour Internet Light Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has the red internet light

Troubleshoot !

The hub 3.0 router from virgin media is showing a red Internet led light, my internet is connected but it’s not working or drops off. (See picture 1, number 1)

Hub 3.0 troublesoot

Hub 3.0 with red internet led picture 1

Remedy !

There are a few things that can cause this see below:

  • First – You need to check the cables and power leads are connected securely.
  • Second – You need to go and see the virgin media website on any known outages on the network, see here.
  • Third – Just simply restart your hub 3.0, I know it sounds easy.
  • Forth – Finally I suggest a factory reset your hub as sometimes it might fix this, find out how here.

If by any reason the hub 3.0 is behaving the same and you have fallowed the instructions above, then call virgin up to investigate further.

Picture of hub 3.0 white and black

Red Colour Phone Light Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has the red phone light

Troubleshoot !

The hub 3.0 router from virgin media is showing a red Phone led light, my landline is connected but it’s not working or drops off. (See picture 1, number 1)

Hub 3.0 troublesoot

Hub 3.0 with red phone led picture 1

Remedy !

There are a few things that can cause this see below:

  • First – I would suggest factory reset your hub as sometimes updates can cause this, find out how here.
  • Second – Check and see the virgin media website on any known outages on the telephone network, see here.
  • Third – Try the resolution from the virgin media website regarding this issue, see here.

If by any reason the hub 3.0 is behaving the same and you have fallowed the instructions above, then call virgin up to investigate further.

Picture of hub 3.0 white and black

Red Colour Wifi Light Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has a red wifi led light

Troubleshoot !

My hub 3.0 router from virgin media is showing a red wifi colour led. (See picture 1, number 1)

Hub 3.0 troublesoot

Hub 3.0 with red wifi led Picture 1

Remedy !

If by any reason you are experiencing the situation above then let’s start.

  • First – you must factory reset your hub 3.0, you can find out how to do this in detail here.
  • Second – you can consider optimizing the hub 3.0 router and setting all wifi to manual optimization, this way you can control it, find out how to do this here.

If by any reason the hub 3.0 is behaving the same and you have fallowed the instructions above, then it’s faulty and you should call up virgin media to send replacement hub or engineer.

Picture of hub 3.0 white and black

Red Colour Power Light Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has the red power led light

Troubleshoot !

The hub 3.0 router from virgin media is showing a red led light, my internet is slow or not working. (See picture 1, number 2)

Hub 3.0 troublesoot

Hub 3.0 with Red Power led Picture 1

Remedy !

There a few things that can cause this, but mainly in this case it’s the high heat see below:

  • First – you must check that the hub 3.0 or router is in a vertical position, in a opened space and the vents are not blocked (the vents are on the sides).
  • Second – you must check that the hub 3.0 is not still hot, as you might need to turn off the power or unplug it and wait at least 20 minutes.
  • Third – try to find a new place to put it on, if you have it in a enclosed and hot place for example.
  • Forth – if you moved it and fallowed the instructions from above as last resort factory reset the hub 3.0, you can find out how here.

If by any reason the hub 3.0 is behaving the same and you have fallowed the instructions above, then it’s faulty and you should call up virgin media to send a replacement.

Picture of hub 3.0 white and black

No Colour Light LED To Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 doesn't have any led light on and I can't connect to the internet

Troubleshoot !

My router or hub 3.0 has no led light and I can’t connect or see the wifi on.

Hub 3.0 troubleshoot

Hub 3.0 with no lights Picture 1

Remedy !

There a few things that can cause this, see below:

  • First – you must check the power switch in the back, has 0 and I. If on should be on I. (See number 5 | picture 2).
  • Second – you must check the power cord and psu.
  • Third – you can replace the power cord only and psu where posible.(Hub 3.0 power slot is compatible with the tivo 500 one)
  • Forth – you must check if you power socket is working or the extension slot if you’re using one.
Hub 3.0

Hub 3.0 back Picture 2

If all the above don’t work then you must call up virgin media and request a replacement hub 3.0.

Picture of hub 3.0 white and black

White Colour Power Light Hub 3.0 Virgin Media Router Troubleshoot

The hub 3.0 has a white led light and I can't connect to the internet

Troubleshoot !

My router or hub 3.0 from virgin media is showing a white linear colour led but I can’t connect. (See picture 1)

Hub 3.0

Hub 3.0 Front Picture 1

Remedy !

If by any reason you are experiencing the situation above there are multiple answers for this.

Now I will focus on the instances that you can make and not the engineer.

  • One – you will need to factory reset your router or hub 3.0, you can find out how here.
  • Second – you can optimize your wifi speeds and range by fallowing my tutorial here.
  • Third – you can check the cables, specially the F ports, splitters or isolator wall box, if they are loose and you can move them with your fingers then they need tightening (use a spanner).
  • Forth – you can move you router or hub 3.0 to a horizontal position if you are using it vertically.

Now if all of the above don’t work, then you will need to call up virgin media and get an engineer to take a look outside.

Picture of hub 3.0 white and black

Hub 3.0 Factory Reset

How to factory reset a Hub 3.0 from Virgin Media

Hello everyone in this small tutorial you will learn how to reset your hub 3.0 the proper way.

As a rule if you ever made any modifications to your hub 3.0, this method will erase and replace everything to factory defaults.

Example you have modified passwords or disabled wifi bands, or simply it doesn’t work.

See pictures bellow, your hub 3.0 might come in white or black colour.

Hub 3.0

Hub 3.0 Front Picture 1


Hub 3.0

Hub 3.0 back Picture 2

Go to the back of the hub 3.0 and find the reset button – see number 3 from picture 2

Use a pin, needle or a pen edge and press it continually for 1 minute while the hub 3.0 is on.

As a rule once you start pressing it the front of the hub 3.0 will turn off all the LED lights.

So pay atention to 1 and 2 from picture 1.

After the 1 minute of continualy pressing the reset button, release and restart the hub 3.0 (press button and get it to “0” position as this will turn off the power, wait 5 seconds, then press button and get it to “I” position as this means power on), see number 5 from picture 2.

This process will reset the hub to factory reset and can take up to 20 minutes to load up.

If it didn’t do anything please repeat the process.